HA Configuration error following VIB install.

I ran into a strange problem with my InfiniBand infrastructure. For some reason, one of my ESXi host would not enter a configured HA mode. I kept getting the “Cannot upgrade vCenter agent on host. Unknow installer error”.

Unable configuring vSphere HA

In my post on how to installing InfiniBand and configuring it on vSphere 5.5, I make a mention of applying the esxcli software acceptance set –level==CommunitySupported command before installing the various drivers, InfiniBand protocol stack (OFED) and the OpenSM package. I must have forgotten to launch that command on a single of my ESXi host. Yet, I was able to install all the InfiniBand drivers.

While trying to find a solution, I came across this VMware KnowledgeBase article kb.vmware.com/kb/2032101 Configuring HA on an ESXi 5.x host fails with the error: Cannot install the vCenter agent service. Unknown installer error  (2032101)

At the bottom of the page, I find the summary, thatthis issue occurs due to acceptance level issues with the vSphere Installation Bundle (VIB) and the host, and to change the host acceptance level to the VIB’s acceptance level.

so I try, to change the acceptance level using esxcli software acceptance set –level==CommunitySupported

But it cannot change the acceptance level because I still have ib-opensm-3.3.16-64 installed. So the trick was to remove the OpenSM VIB, change the host acceptance level for the VIB, reboot the host, make sure VMware HA can be enabled and I reinstalled the ib-opensm-3.3.16-64 VIB afterwards.

Remove ib-opensm dryrun

esxcli software vib remove -n ib-opensm

esxcli software acceptance set –level==CommunitySupported

reboot

Ensure vSphere HA can be installed

esxcli software vib install -v /tmp/ib-opensm-3.3.16-64.vib –no-sig-check

 

Hope this can save someone some trouble at some point.

 

 

 

 

 

 

  • groche

    And if you manually install vmware-fdm with –no-sig-check ?

  • Jason Leibin

    You rock…I’m in the process of building my first lab, using infiniband. I’ve read many of your excellent articles on your experiences, and this one too just helped me around the HA issue. Thank you Erik!

    Jason

  • Kev

    great post, little issue with the command though

    esxcli software acceptance set –level=CommunitySupported

    was accepted rather than

    esxcli software acceptance set -level==CommunitySupported